If you have a nice GDI printer Xerox Phaser 3117, you will wonder there’s no driver for Mac OS X and Xerox website says this printer is not supported in Mac OS X 10.6.

As you know Mac OS X uses Apple’s developed CUPS (Common UNIX Printing System), so I’ve been used this printer on FreeBSD with Samsung GDI driver, but that wasn’t working via Mac’s interface. Even though there’s a special drivers build for this printer Splix, that was not working properly.

So you need to install 3 packages and select installed driver for your GDI printer:

  1. Samsung GDI (180 KB)

    The samsung-gdi package includes PPDs for 26 Samsung-GDI printers.

    The samsung-gdi package includes PPDs for 26 Samsung-GDI printers.

  2. Foomatic-RIP (640 KB)

    The Foomatic-RIP package installs the necessary core runtime components to enable printing with Foomatic machinery in Mac OS X. This package is generally not useful without Ghostscript and at least one foomatic PPD.

  3. Ghostscript (33 MB)

    GPL Ghostscript is an open-source PostScript interpreter that includes integrated support for the CUPS printing system in Mac OS X. It is the replacement for ESP Ghostscript.

Packages sources are listed here.

And then select the installed driver for your printer:

You’re done!